Microsoft Office 365/Teams Service Outage
Incident Report for Razor Tech
Resolved
Microsoft has fully resolved this outage and is no longer reporting any issues with services.
Posted Sep 29, 2020 - 08:06 EDT
Monitoring
Microsoft has confirmed via their monitoring that the majority of services have recovered for most customers. However, they continue to see a small subset of customers whose tenants are located in North America region who are still impacted. They are now investigating mitigation steps for those customers who are still affected.
Posted Sep 28, 2020 - 22:26 EDT
Identified
Microsoft has determined that a specific portion of their infrastructure is not processing authentication requests in a timely manner. They are currently pursuing mitigation steps for this issue. In parallel, they have begun rerouting traffic to alternate systems to provide further relief to the affected users.
Posted Sep 28, 2020 - 20:23 EDT
Investigating
We are currently investigating a wide spread outage affecting all Microsoft services.

Microsoft notes that users would be unable to access Outlook.com, Microsoft Teams including Teams Live Events, and Office.com. Additionally, Power Platform and Dynamics365 properties are affected by this incident.

Microsoft has identified that reverting the recent change did not alleviate impact to Microsoft services as expected and are working to explore additional options for mitigation.

We will update the outage incident as more details are provided by Microsoft.
Posted Sep 28, 2020 - 19:44 EDT