Microsoft Office 365/Teams Service Outage
Incident Report for Razor Tech
Resolved
Microsoft has resolved the issues with the Azure Active Directory services and users are no longer reporting issues.
Posted Mar 15, 2021 - 22:27 EDT
Monitoring
Microsoft has provided an update to the outage and are currently monitoring the issues reported. Microsoft 365 services continue the process of recovery and are showing decreasing error rates in telemetry. We’ll continue to monitor service health as availability is restored.
Posted Mar 15, 2021 - 18:11 EDT
Investigating
We've identified a core Microsoft service issue and are tracking updates of the issue here:
https://status.azure.com/en-us/status.

Any services which are configured to leverage Azure Active Directory as the authentication source are currently impacted.

We will continue to update as we receive more information.
Posted Mar 15, 2021 - 17:01 EDT